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Introduction 

As Open Green Map (OGM) platform grows, more mapmakers have asked for their data (all sites 
published on their Open Green Maps) to be available offline. While Green Map System assures 
mapmakers the security and the online availability of the data stored on the OGM, we have also 
added a new export feature for mapmakers that wish to access their data as a CSV or KML file in 
order to be manipulated in spreadsheets, database management systems or Geographical 
Information Systems (GIS). 

This tutorial reviews the steps to export your map data from OGM, work with the exported files, import 
these files into a spreadsheet and bring the data into a GIS. 

Back to Contents 

Who is this tutorial for? 

This tutorial is for people that wish to access their sites (already mapped on OGM) outside of the 
OGM platform as a CSV, a KML file, a spreadsheet or as a GIS file (such as shapefiles).  Little or no 
experience in handling spreadsheet software is required and some GIS knowledge is helpful.  

Back to Contents 
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Definitions 

CSV = A Comma-Separated Values (CSV) file is used for the digital storage of data in a table 
structured in the form of lists. Each line in the CSV file corresponds to a row in the table. Within a line, 
fields are separated by commas, each field belonging to one table column. Since it is a common and 
simple file format, CSV files are often used for moving tabular data between two different computer 
programs, for example between a database program and a spreadsheet program. Read more about 
CSV at http://en.wikipedia.org/wiki/Comma-separated_values  

GIS = A Geographic Information System (GIS) captures, stores, analyzes, manages, and presents 
data that is linked to location. Read more about GIS at 
http://en.wikipedia.org/wiki/Geographic_information_system  

KML = Keyhole Markup Language (KML) is an XML-based language schema for expressing 
geographic annotation and visualization on existing or future Web-based, two-dimensional maps and 
three-dimensional Earth browsers. KML was developed for use with Google Earth, which was 
originally named Keyhole Earth Viewer. Read more about KML at http://en.wikipedia.org/wiki/KML  

UTF-8 = UTF-8 (8-bit UCS/Unicode Transformation Format) is a variable-length character encoding 
for Unicode. It is able to represent any character in the Unicode standard, yet is backwards 
compatible with ASCII. For these reasons, it is steadily becoming the preferred encoding for e-mail, 
web pages, and other places where characters are stored or streamed. Read more about UTF-8 at 
http://en.wikipedia.org/wiki/UTF-8  

Back to Contents 
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Software and OGM Requirements 

In order to follow the steps of this tutorial, you need the following: 

Access to www.OpenGreenmap.org  as a Mapmaker or Team coordinator (team members won’t have 
access to this functionality); 

Access to either one of the following spreadsheet software:  

• Microsoft Excel  - a proprietary commercial software 
http://office.microsoft.com/en-us/excel/default.aspx  

• Notepad++ - useful tool to handle CSV UTF-8 encoding 
http://notepad-plus.sourceforge.net  

• OpenOffice Calc – an open source software 
http://www.openoffice.org/product/calc.html  

Access to either one of the following GIS software:  

• ArcGIS Desktop 9.2 or newer version  – a proprietary commercial software 
http://www.esri.com/products/index.html#desktop_gis  

• Quantum GIS Mimas 1.3.0 – an open source GIS  
http://www.qgis.org/ 

• DIVA-GIS – an open source GIS  
http://www.diva-gis.org/  

• Global Mapper 11 – an inexpensive commercial GIS software 
http://www.globalmapper.com   

Back to Contents 
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How to Export Files from Open Green Map 

Login at www.opengreenmap.org as a Mapmaker or Team coordinator, go to your map profile and look 
for a similar tab menu like the one below: 

 

There are three types of files that can be exported from your Open Green Map:  

1. A CSV file, named map_export.csv, which contains the following fields: 

Site ID, Name of Site, Authored By, User ID, Authored On, Last Edited, Primary Term, Icon, Tags, 
Details, Language, Appointment Needed, Children Welcome, Volunteer, Details of Volunteer 
Opportunities, Accessible by public transport, Public Transit Directions, Telephone, Site Email, Free 
entry, Entry cost, Web Address, Wheelchair Accessible, Street location, Additional, City, Postal Code, 
Latitude, Longitude, Maps, Map IDs, Public Site, Contributor Directly Involved In Site, Contributor 
Name, Contributor Email, Image, Image caption or credit, Video, Video caption or credit, Awaiting 
Approval, Published 

 

http://www.opengreenmap.org/�
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The exported CSV file is encoded using UTF-8 encoding system and has line-breaks embedded, so 
extra attention has to be paid on formatting and importing it correctly to Microsoft Excel or OpenOffice 
Calc.  

See Working with CSV Files in spreadsheet software for further instructions. 

2. A KML file (with regular labels), named map_export_labels.kml. This file type contains fewer 
fields. It can be opened with Google Earth where the icons and labels are visible.  

In this KML format it uses the Green Map Icons (copyrighted), which are loaded from the OGM 
server. This KML file may also be imported into a GIS using the appropriate tools. 

 

By clicking on the icon the description of the site appears.  
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The "View More and Share Into at Open Green Map" link connects this exported file back to the OGM 
website where users can view multimedia related to the site, post comments and note the impacts of 
the site in their life.  

 

http://www.opengreenmap.org/node/193 

 

3. A KML file (with transparent labels), named map_export.kml can be exported as well.  

 

This KML file has the same capabilities as the KML file without labels that have just been described.  

Back to Contents 
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Opening the CSV file as a Spreadsheet 

In order to properly open the CSV file in Microsoft Excel or OpenOffice Calc, we need to follow 
particular steps, especially when the CSV contains hundreds or thousands of records. 

Choice 1: Importing to Microsoft Excel 

Choice 1A is recommended for CSV files that contain only ASCII characters (such as text written in 
English). This particular CSV file may be opened directly in Excel 2003/2007 and the resulting data 
will appear in a table that can be manipulated and imported into GIS.  

Choice 1B needs to be followed if your exported CSV file contains foreign characters (such as 
accented characters).  

Choice 1C will work in most cases if your CSV file contains foreign characters and line breaks 
(usually from fields such as descriptions or addresses). This option is useful if you wish to preserve 
the entire content in long site descriptions. 

Choice 1A: Open the CSV directly in Excel. 

1. File > Open. The result should look like: 

 

2. If you can’t see gibberish data such as on the above image, then you are done opening the 
CSV file. Otherwise, please follow the instructions on step B below. 
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Choice 1B: Import using Text Import Wizard 

1. Create a new spreadsheet, and then go to  

2. Excel 2007: Data > Get External Data > From Text (see below) > Import Text File  

 

3. Now, choose Text File as the file type to search for. 

4. Browse for your CSV file, and then hit Import.  

5. A new Text Import Wizard shows up and needs input from you in 3 steps.  

6. Choose Delimited for the file type, then File Origin: 65001: Unicode (UTF-8), like in the image 
below: 

 



11 | P a g e  

 

If your CSV file contains line breaks, you will most definitely observe at this step (see the image 
above), where the Site ID does not show up the IDs at each row. In this case, you will need to follow 
Step C explained below.  

Choice 1C: CSV to Microsoft Excel via Notepad++ 

Our recommendation is to use the following open source solution in order to fix the UTF-8 and line 
breaks issues before opening the CSV in Microsoft Excel: 

1. Go to http://notepad-plus.sourceforge.net and install Notepad ++. 

2. Once you open the file in Notepad ++, go to Format > Encode in UTF-8. This patch adds the 
UTF-8 byte order mark or BOM (check the UTF-8 definition for BOM) to the start of the CSV 
file so Excel will display its contents correctly. 

 

http://notepad-plus.sourceforge.net/�
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3. Now you may open the file in Microsoft Excel, now correctly showing the foreign characters. 

For example: 

 

Back to Contents 

Choice 2. Importing into OpenOffice Calc. 

1. Open the file directly.  

2. A Text Import window will appear. By default, the character is set to Western Europe 
(Windows-1252/WinLatin 1). Change the character set to Unicode UTF-8 and all other 
parameters like in the image below. 
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3. The contents will display correctly. If not, check the settings again.  

 

Back to Contents 
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 Convert CSV to Shapefile 

The CSV file you exported from OpenGreenMap.org may include regional characters; therefore our 
developer team chose the UTF-8 encoding system in order to accommodate characters from various 
languages. 

Though GIS software such as ArcGIS, Quantum GIS, Diva-GIS or Global Mapper have the 
functionality to open the CSV directly, it proved that this exported CSV file won’t import that easily. 
Therefore you need to follow the next preliminary steps in order to bring all your data into a GIS. 

Preliminary steps  (See: Opening a CSV File as a Spreadsheet) 

If your CSV does not contain accented characters, then simply open the file in Excel or 
OpenOffice Calc. and save the file as XLS. 

1. Make sure the CSV is UTF-8 encoded with Byte Order Mark (BOM). 

 

2. Open the file with Microsoft Excel or OpenOffice Calc (choose UTF-8 encoding). 

 

3. Save the CSV as XLS file (.xls).  

Back to Contents 
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Choice 1. ArcMap from ESRI ArcGIS Desktop 9.3 

1. Create a new map in ArcMap or open an existing map that you wish to add your OGM sites 
to.  

2. Import the Excel file by clicking on the Add Data button:  from the main toolbar:  

 

3. Find your Excel file.  Once you find the Excel workbook you must double click on it and find 
the spreadsheet within the workbook that you would like to add.  Then click “Add.” 

4. You will now notice your spreadsheet as a data table in the Source view of the Table of 
Contents: 

 

5. We can use the latitude and longitude information in this data table to geocode the OGM 
Green Sites as points that will make up a new shapefile. Right click on the data table and 
choose “Display XY Data.” 
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6. The following window will show up and you should define the X and Y fields as X = Longitude 
and Y = Latitude.   

 

7. Click “Edit” to choose a coordinate system.   

 

8. Open Green Maps uses a Google Maps API, whose internal coordinate system is geographic 
coordinates (latitude/longitude) on the World Geodetic System of 1984 (WGS84) datum. 
 
So, we recommend you to select: Geographic Coordinate System > World > WGS1984.prj 
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Should you need to project your shapefile to a different system, you may do so once you 
create a shapefile.  

For more information on projections and coordinate systems see this help guide from ESRI: 
http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?topicname=what_is_a_map_projection?  

9. The results appear as an Event and not an editable shapefile.  

 

10. To create a shapefile from the event, right click on the “Event” while viewing it in the “Display” 
view of the Table of Contents.  Then Choose Data > Export Data. 

 

http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?topicname=what_is_a_map_projection?�
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11. Then save the exported shapefile to your workspace.  When the following message appear 
choose “Yes” to add the new shapefile to your Map as a layer. 

 

12. Your Map will now have a new shapefile in the table of contents.  

 

13. When we view the attribute table: 

 

It seems that ArcMap did not import the long text fields, which also include text over multiple lines. 
One solution that we recommend here is bringing the text separately into a Microsoft Access 
Database (*.mdb) and then do a join or relate it with the shapefile based on a common unique 
field such as Site_ID. 

For more information about geocoding with ArcMap see this ESRI guide: 

http://support.esri.com/index.cfm?fa=knowledgebase.techArticles.articleShow&d=27589  

Back to Contents 
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Choice 2. Quantum GIS 1.3.0 

1. In order to make it work, I had to format the CSV file as tab-delimited and erase the double 
quotes, as well as take out the details field which contains line breaks.  

2. Then I used the Delimited Text Layer Plugin from QGIS.  

3. Check your settings and remember to click on parse button until you see that Longitude and 
Latitude are selected the same way as on the screenshot below: 

 

4. The result should look like below: 
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5. Unfortunately errors like rows not being imported or gibberish data may appear. So far, I 
haven’t identified why this occurs. But let’s continue…  

  

6. Right-click the layer test and choose “save as shapefile”: 

 

7. Choose UTF-8 encoding… 
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8. Select WGS84 (EPSG:4326) for Coordinate Reference System. Hit OK. 

9. Let’s check the file that I called test.shp. Click on Layer > Add vector layer: 

 

10. Now you have your shapefile in Quantum GIS. 

 

Back to Contents  

Choice 3. DIVA-GIS 7.1.6 

DIVA-GIS has several options to import our data to shapefile. You may choose TXT, XLS, MDB or 
DBF.  For this tutorial, I chose to import the DBF. If you want to keep the details field, then I would 
recommend you use the MDB. 
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1. Choose input file, if you properly formatted the latitude and longitude fields as numbers, then 
X and Y fields will display LONGITUDE and LATITUDE. Now choose the output shapefile. Hit 
Apply and Close. 

 

2. The attribute table looks a bit odd again. DIVA-GIS does not display the contents using UTF-
8, perhaps it depends on the system Locale which is set to US on my computer. Perhaps if it 
was set to Latvian, it would display correctly. 

 

Back to Contents 
 

Choice 4. Global Mapper 11 

Same as in DIVA-GIS, I used the DBF format to open it in Global Mapper. 

1. Open the DBF file. A DBF file import window will appear. Check for X and Y fields. 
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2. Global Mapper will recognize the two fields that represent the geographic coordinates. Hit OK. 
Now you need to select the right coordinate system: WGS84 in our case. Hit OK. 

     

3. Now, go to File > Export Vector Data > Export Shapefile (or any other format that you need). 
Check Export Points and select the location where to save the shapefile. Hit OK. Now you 
have your shapefile. 
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Back to Contents 



25 | P a g e  

Convert KML to Shapefile 

Choice 1: Convert KML to SHP using ArcGIS Desktop 9.3.1 

1. Download the “Convert to KML files to shapefiles” arcscript from 
http://arcscripts.esri.com/details.asp?dbid=15603 

2. Read the Installation Guide (.pdf) included in the zip file downloaded from the above URL. 
The installation instructions are very well written and not repeated here in the tutorial. 

 

3. Once you have loaded the toolbox called Convert KML to SHP, then run the tool and browse 
for the KML file, change Feature Type to Point, and hit OK to convert KML to Shapefile. 

 

 

http://arcscripts.esri.com/details.asp?dbid=15603�
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4. If you get errors such as the one below, follow the advice in the troubleshooting section of the 
script guide. 

 

5. The script does not read older kml formats. If the script has a problem reading a kml file, you  
should try recreating the file in Google Earth v4.2 or later. To do this, load your kml file into 
Google Earth, right click on the file under "Places" and choose "Save Places As" to resave the 
file. Make sure to choose kml as the file type not kmzTry running the new kml file in the script. 
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6. If you correctly followed the instructions, now you may have a shapefile with the attributes 
table containing the ID, name, description from the KML file. 

 

Back to Contents 

Choice 2: Convert KML to SHP using Global Mapper 11 

1. File > Open Data File > Open the file map_export_labels.kml 
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Global Mapper will open the file and recognize the coordinate system automatically (see the 
menu Tools > Configuration > Projection) 

 

If your data needs a specific projection, you may change that here by selecting the projection 
and datum from the drop-down lists. The results will take effect immediately. 

2. Export to shapefile or a different GIS format (and Global Mapper offers lots of choices) is easy 
following the menu: File > Export Vector Data > Export shapefile. 
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3. Click OK at the next window or follow the instructions to change to the preferred projection. 

 

4. A new window called Shapefile Export options will appear. Here you need to check Export 
Points and browse for a location of the shapefile. Click Save. 
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5. Now click OK to start exporting the shapefile. 

6. Try to open the file in Global Mapper, and check the Overlay Control Center. 

 

 

Back to Contents 
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Reader Feedback or Questions 

Feedback from our readers is always welcome. Let us know what you think about this tutorial, what 
you liked or may have disliked. Reader feedback is important for us to develop tutorial that you really 
get the most out of. 

To send us general feedback, simply drop an email to greenmap@greenmap.org, making sure to 
mention the tutorial or a link to it in the subject of your message. 

If there is a topic that you have expertise in and you are interested in either writing or contributing to a 
tutorial, please do write at greenmap@greenmap.org 

Back to Contents 
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